Sorry! Our servers require the highest level of SSL encryption - Make sure your browser supports TLSv1.2

To enable TLS 1.2 on older versions of Internet Explorer follow these steps:

  • On the Internet Explorer main menu, select Tools > Internet Options
  • In the Internet Options box, select the Advanced tab
  • In the Security category, uncheck Use SSL 3.0 and check Use TLS 1.2
  • Click OK
  • Exit and restart Internet Explorer

  • SALES : 855-238-4445 option 1
    EMAIL : sales@vigilantnow.com
     
    SUPPORT : 855-238-4445 option 2
    EMAIL : support@vigilantnow.com